AlpacaTech Blog

備忘録。ゲーム作りたい系草食動物

【Unity】PackageManagerでUpdateが適応されない

 結論

根本的な理由がわからなかったので、

キャッシュ消して再インストールしました。

 (普通の再インストールでは駄目だった)

 

概要

共同で作成しているプロジェクトで、

自分の所だけPostprocessing関係で例外が出まくる。

 

PackageManager確認したら最新じゃなかったので

f:id:alpacatech:20180707143600p:plain

最新版にUpdateしようと 

Updateボタンを押しても反映されませんでした。(2.0.7にならない)

 

jsonファイル等を触ってみたり色々試したけど解決できませんでした。

ネットにも情報がなかったりと解決策が見つからなかったので、

再インストールすることにしました。

(5.XX時代から上書きインストールを重ねていたフォルダ)

 

再インストール

普通にインストールしなおしだと解決しなかったので、

色々綺麗にしてインストールしなおしました。

 

手順

アンインストール以外にキャッシュ消したりしているので自己責任でお願いします

アンインストール

f:id:alpacatech:20180707144450p:plain

Assetのキャッシュデータを削除

C:\Users\[USER_NAME]\AppData\Roaming\Unity\
C:\Users\[USER_NAME]\AppData\Local\Unity\

を削除(念のためリネーム)

 

再インストール

インストーラーでインストール。

 

インストール後

f:id:alpacatech:20180707144626p:plain

2.0.7になっていました。